4

Object Editor Point Editor

The Object/Point Edit button [P] on the toolbar changes Anim8or into Object/Point editing mode. Here you can modify individual points, edges and faces of any mesh object. You can move, scale, rotate, add and delete them. You can extrude, twist and scale faces, weld close points together, etc. When you enter Object/Point Edit mode you will usually want to change the display into wireframe with the View→Wire [Ctrl-W] command.

Object/Point Operations

Just below the coordinate system button row there is a new row of three buttons: . You use these to change the selection mode to point, edge or face in order to select different parts of your model. The select and drag select modes will then select the corresponding items.

There are two buttons that you will find helpful when selecting points, edges and faces. They control whether you can select front facing [[] and back facing []] faces, edges and points. By default both kinds are enabled. Click on the buttons to toggle the setting.

Point Editing

You use point select mode [p] to modify the shape of an object, and to add and delete unwanted parts of an object. You can manipulate selected points by using any of the move, rotate, and scale buttons. The rotate and scale operations are done relative to the objects pivot.

If you delete points using the scissors button [Ctrl-X], or the delete key [Del], any edges and faces that contain those points are also deleted. For example, to delete the bottom of a sphere, first select all of the points below but not including the equator using drag select mode, and delete them

If you move these same points, scale them non-uniformly , or scale them , you can make objects like these:

   

You can use the Arrow Keys on the keyboard to make tiny moves, rotations, and scales to selected points as well when the corresponding toolbar button is enabled.

In move mode, click-dragging with the middle mouse button (or alt-right) will move individual points along their normals instead of relative to the screen.

Edge Editing

You use edge select [e] mode in a similar manner to point select mode. When you select an edge, both of its end points are also selected. Thus all operations from point select mode are enabled as described above.

If you delete using the scissors in edge mode, however, only the selected edges and any faces that contain them are deleted. All points are saved. This allows you to change the tessellation of an object more easily, without having to add back previously deleted points.

You can also set various edge properties for selected edges. Select the edges you want to effect, and then select the Edit→Edge-Properties command. The default setting for edges is smooth. This means that if the solid angle defined by the two faces is less than a certain threshold, the edge will be smooth. Otherwise it will be creased. You can change the value of this angle by double clicking on a mesh when in Object/Edit mode to bring up its parameter dialog.

You can mark an edge as creased, so that it won't be drawn as a smooth surface but will appear as a sharp crease. This does not change the geometry of the model in any way; just the way normals are computed so that it appears smooth or creased. The following sphere has the lower half of its edges set to creased:

Another property that you can set in this dialog is how rounded an edge will be after it has been smoothed. Normally when a mesh is smoothed, all edges become smoother. Each application of smoothing increases the number of faces in a mesh, and smoothes all edges. You can mark any edge so that it will not be smoothed, but will retain a sharp crease, for one or more cycles of smoothing. The following shows a cube and several possible smoothings of it:

The sphere-like ball is the result of a simple cube being smoothed several times. The top two rounded cubes are the result of smoothing a cube with all of its edges set to a rounded level of 1 and 2. The bottom two rounded cylinders are from a cube with only the top 4 and bottom 4 edges set to a rounding level of 1 and 2.

Face Editing

You use face select [g] mode to select and manipulate the faces of a mesh. You can delete selected faces with the scissors button or delete key, but points and edges remain unchanged. You cannot move, rotate or scale selected faces with the normal buttons. This is because it is somewhat ambiguous as to what you intend to do when several adjacent faces are selected. There are, however, specific tools for these tasks that are described below.

Selected faces are shown as filled even in wire frame mode. The front side is shaded YELLOW and the backside BLUE to help you see what faces are selected. This is also the case in filled mode, but you usually only see the yellow front sides.

   

Applying Multiple Materials

You can also apply different material properties to individual faces. Simply select the faces that you want to change, display the material toolbar (use Options→Materials [Ctrl-M] if it isn't already visible), select the material to apply, and click the apply button in the toolbar.

You can use as many materials on a mesh as you want. With a little imagination you can make objects like these:

The UV texture tool is also available in the Point Editor. You first select the faces that you want to texture, and then use the UV tool to interactively apply the coordinates. It helps if you already have a textured material applied to those faces.

A Note on Selecting Faces

It can sometimes be rather tedious to select the exact faces that you want, especially in a complex model. There are several tricks that can help out.

The select mode selects faces that are facing the viewer over those facing the other way. Often changing the view of an object, or rotating the view with the arc-rotate tool, so that different faces are in front, can help. This is one reason that selected faces are shown in YELLOW even in normal views where you normally can't modify individual faces.

The drag select mode only selects faces that are entirely within the selection rectangle. You can often add faces one-by-one until you've selected what you need. The front/back buttons can be useful here as well.

Adding Points and Edges

You can add new points and edges to a model with the Add Edge button in the toolbar. To add edges to an existing object, click on one of its points and drag the mouse out. A new edge and point will be added where you release the mouse. If you move the mouse to an existing point the end of the edge will snap to the existing point, thus creating an edge between the two points. You can build complex meshes quickly using this method:

If you want to add a point that is close to another one but not make it the same point, hold down the Shift key after you click the mouse button down and hold it until you release the mouse.

If you want to start a new mesh, press the Shift key before you press the mouse button. A new mesh will be created with a single edge and 2 points.

Note: This command only adds Points and Edges, not Faces. You can use the Edit→Fill-Holes [J] command described next to add new faces.

If you enable grid snap [Ctrl-G] when you add points you can make objects with exact measurements more easily.

Adding Faces

Once you have added new edges to a mesh, you will be able to fill in the gaps with new faces. You do this by first selecting all of the edges that surround where your new face or faces will go. Then you use the Edit→Fill-Holes command to fill them.

There are a few things to note before you start adding faces:

Connecting Meshes

You can attach two separate meshes to create a single, connected mesh using the JoinSolids, Add Points/Edges and Add Faces commands.

Merging Points

You can merge separate points into a single point with the Edit→Merge-Points [L] command. First select the points that you want merged. It is best if they are very close to each other to begin with. Then apply the Edit→Merge-Points command. A dialog appears where you can enter the maximum distance allowed between pairs of points. Click OK and all eligible pairs will be merged.

Connecting Meshes (2)

You can also use this technique to connect two meshes. It works best if the connecting point sets are similar in size and number. For example connecting half of a Sphere that has 12 longitude lines with a cylinder with 12 sections around is a snap.

Connecting Meshes (3)

You can often build one half of a symmetrical object, then mirror it with Build→Mirror and join the two halves into a single mesh with Build→Join-Solids Then position the two halves close together, select the adjacent points and use Edit→Merge-Points in the Point Editor to make a seamless connection. This merged object was then smoothed one time to round off the corners.

Point and Line Parameters

When you are in Point Select mode you can double click on a point to bring up a dialog box that lets you read and alter its position numerically. This is very useful when you want to precisely position a part of a mesh when building a mechanical model.

When you are in Edge Select mode you can similarly double click on an edge to edit its properties.

Face Extrusion and Manipulation Tools

You can manipulate selected faces in a variety of ways using the lower group of buttons in the toolbar. They can be used to build very complex models from a small number of primitive shapes using the box modeling method.

The extrude [X] tool extrudes all of the selected faces. Each face is translated in the direction that it faces, either out or in, and new polygons are added to connect the face to its original location.

Similar to the extrude tool, the extrude-connected [Y] tool extrudes selected faces in a Mesh. However adjacent selected faces remain connected. New faces are only added to the edges between a selected and an unselected face.

   

In the image above the 6 faces on the first solid are shown extruded and extrude-connected.

This button rotates [R] each selected face around its center. It's most useful when the selected faces aren't adjacent.

   

You can scale [K] selected faces using this button.

   

This one will replace faces with a peak [P].

The bevel [b] tool is useful for adding beveled corners to surfaces. You can bevel faces, edges and points of any mesh. Selected edges are turned into new faces, cutting the corner off of the original model as shown below:

The inset [I] tool is also useful for adding faces to surfaces. Each selected face is replaced by a smaller version of itself and new faces that connect it to the original edges. This is an easy way to add more detail to a particular part of a model, or to make a hole for a door, window, or eyes.

The shell [u] tool adds thickness to the walls of a Mesh. To make a shell simply click on a Mesh or a Subdivision Object and drag the mouse. The basic Mesh cannot be completely closed. It must have at least one "missing" face.

The bump [B] tool raises all the selected faces up on a bump.

If you want to cut a slice through a model you'll find the cut faces [C] tool quite handy. It slices through edges and faces when you click-drag the mouse across an object. If you slice all the way across an object as shown below you can then use the Edit→Loop-Cut command.

You can divide a face into two by clicking on one vertex and dragging to another. The connecting line will snap to a vertex when you click nearby. Or you can disable the snapping if you press and hold the Shift key when applying a cut. You may want to disable the back facing edges from being cut as well by turning off the button.

The slide [S] tool lets you slide a point along an edge, or extend the edge. Just click on a point and drag the mouse in the direction of one of the edges that enters it. This will select the active edge and shorten it. If you want to lengthen it instead just keep dragging but in the opposite direction.

The edge extrude [E] tool extends your object for all selected edges that have only one face with another face.

When you use these face manipulation operations you may wish to convert your mesh into a subdivision mesh with the Build→Convert-to-Subdivided command in order to build more complex shapes. For example, start with an extruded pentagon, select all 5 outer faces, extrude them, and convert to subdivided to make a starfish:

Face Editing Commands

Anim8or has several other useful face editing commands. You will find them under the Edit menu in the Point Editor.

The bridge [=] command allows you to do several useful operations. To use it you first select two different faces. They have to have the same number of edges but can belong to different Meshes if you want. The Edit→Bridge command will then connect the two selected faces with new faces. You can poke holes through a Mesh:

You can connect two parts of a Mesh to form a bridge:

And you can join two different Meshes into a single mesh:

The flatten command does just what its name suggests: it flattens groups of selected faces. All the vertices of each group are projected onto a flat plain. You can choose the group's average face direction or the X, Y, or Z-axis. Flattening is quite useful when you need a level base for a model, and can be use with the merge face command to help simplify your models.

The merge faces [M] command combines groups of selected faces into a single face. You can simplify areas of your models that are too detailed this way.

You have to be careful to keep the faces convex and relatively flat or they may not render properly. Convex faces are those that don't have any points inside their outer boundary. Faces with interior points are called concave and can cause rendering errors:

In the example shown above three pentagonal faces are merged into one big face with 9 sides. It is concave and doesn't draw properly as a result. It's easy to see in this example because of the stray back facing part that is blue when selected. Other times it may not be as obvious what is wrong.

If you are working with a Subdivision object this is not as important. The faces that you are editing aren't drawn in your final object. Subdivision will smooth the mesh making it much better formed along the way.

Miscellaneous Commands

There are several miscellaneous commands in the Point Editor that you will find useful. One group helps you make certain useful of selections that could otherwise be quite tedious. The other group modifies objects in various ways.

Selection Commands

A quad loop is a chain of adjacent quads, or 4 sided faces, that are attached across opposite sides. The quad loop select [q] command extends selected edges along quad loops as long as there are exactly four faces joined together at each vertex. For models like the sphere below this results in a closed ring around a latitude line. For vertical edges it only extends to the poles since there are more than four faces sharing the pole points.

The quad ring select [Q] command works on chains of adjacent quads, or 4 sided faces. When a quad has a selected edge, the opposite edge is also selected. This is repeated until all quads in a "ring" are selected, or until a face without 4 faces is encountered. (Selections are shown in red here to make them better visible against a white background.)

You will find these commands under the Edit→Select menu.

Editing Commands

connect edges [j]

adds new edges between the centers of any selected edges that share a face.

cut edges [Z]

splits each selected edge into two in the middle.

subdivide faces [U]

divides those faces into several smaller faces. It does this by adding a new point in the center of each selected face and connecting it to the points of that face.

loop cut [l]

splits a mesh into multiple parts along closed loops of selected edges.

spin quads [/]

Spin quads is a useful tool for modeling. It changes which corners of a face are connected by rotating an edge to adjacent points. The faces adjacent to the selected edges must have 4 sides, hence the name.

These commands are under the Edit menu.

select malformed edges

selects any edges that are in 3 or more faces. These edges can have unpredictable side-effects when you edit or render.

select orphans

selects any points and edges that are not currently being used in a face. This can help you remove unnecessary geometry from your models.

These commands are under the Edit→Select menu.